1

Topic: A link to the Mysql server could not be established

Windows password for LDAP connection has been changed recently. After that our GLPI system can be login, even logon by the default account (e.g. glpi, etc.).

A message (A link to the Mysql server could not be established. Please check your configuration) is now prompted on the front page of GLPI, the logon box even cannot be displayed.

Any one know how can it be fixed?

Thanks and regards!

2

Re: A link to the Mysql server could not be established

Look at glpi/config/config_db.php

Prod : RHEL 4.6/5.4 - php 5.1.6/5.2.13 + APC + memcached - MySQL 5.0.45 - OCS 1.01 - GLPI 0.83.8 svn  (>130 000 PMF - 334 entités)
Dev : Fedora 14 - PHP 5.4.12 - .GLPI 0.84 SVN - GLPI 0.85 SVN
Certifiée ITIL (ITV2F, ITILF, ITILOSA)

3 (edited by sweetjessan 2012-06-09 07:41:48)

Re: A link to the Mysql server could not be established

Hi, what changes must be apply in config_db.php

what can i see are the ff:

<?php
class DB extends DBmysql {
               
var $dbhost = 'localhost';
               
var $dbuser     = 'root';
               
var $dbpassword= '';
               
var $dbdefault    = 'glpi_db';
               
}
?>


Pls. do help me guys....

4 (edited by FabFara 2012-06-09 21:17:04)

Re: A link to the Mysql server could not be established

Os type and version?
The password of  mysql user is correct?
You have recently updated your mysql??


Chek the sql log for some detiled error  (/var/log/mysql)

GLPI 0.83.7 - MySQL 5.1.69 - PHP 5.3.3 - CentOS 6.4 64 bit

5

Re: A link to the Mysql server could not be established

Hi FabFara,

Thank you so much and I forgot to put the password for mysql

and now it's working.

Thank you...