1 (edited by jevrej 2008-05-13 17:06:09)

Topic: Network Architecture plugin - problems

Hi all,

i installed glpi 0.70.2 and network architecture plugin 1.5 and import all computers from ocs, i also add 2 switches and connect several servers to them. But i could not get any of picture just
Test Graphviz with abcd circles. So i have several questions:
1. Exist some tutorial for this plugin?
2. What is necessary to be set for final picture?
3. is possible to get an partial picture or its necessary to set all of computers?

GLPI looks great but  with mostly no documentation  i feel lost in it.

thanks for any help

Daniel

2

Re: Network Architecture plugin - problems

Try with this guide :

http://glpi-project.org/wiki/doku.php?i … chires_use
Bye

Glpi 0.83.7 - production  and testing - OCS 2.0.5  - Mysql 5 - Apache 2 - php5 - Ubuntu server LTS 10.04.4 LTS
Plugins:    behaviour, position, generic object, sim management, web services, projects _______________________________________________

3

Re: Network Architecture plugin - problems

Sorry but this is not guide - i have installed the plugin with no error messages - but i see just Test Graphviz with abcd circles.
Daniel

4 (edited by artickl1 2009-07-23 19:40:55)

Re: Network Architecture plugin - problems

I have the same problem... Install correct without any problem. Configure pictures, colors, views... But no pictures there... I found test.php in plugin folder - if I try to open it - it's taking me file test.php to save it (if firefox) but it's a png picture in there.

And one more - firefox error console have this errors:
"Warning: Unknown property 'zoom'.  Declaration dropped.
Source File: http://192.168.1.20/glpi/css/styles.css
Line: 911"

Warning: Unknown property 'zoom'.  Declaration dropped.
Source File: http://192.168.1.20/glpi/css/styles.css
Line: 914

Warning: Error in parsing value for 'top'.  Declaration dropped.
Source File: http://192.168.1.20/glpi/css/styles.css
Line: 1077

Warning: Error in parsing value for 'width'.  Declaration dropped.
Source File: http://192.168.1.20/glpi/css/styles.css
Line: 1078

Warning: Expected ',' or '{' but found '/'.  Ruleset ignored due to bad selector.
Source File: http://192.168.1.20/glpi/css/print.css
Line: 31

Warning: Selector expected.  Ruleset ignored due to bad selector.
Source File: http://192.168.1.20/glpi/css/ext-all-glpi.css
Line: 2

Warning: Unknown property 'text-overflow'.  Declaration dropped.
Source File: http://192.168.1.20/glpi/css/ext-all-glpi.css
Line: 20

....




System
uname:
Debian Lenny 2.6.26-2-686

Packages:
(sudo dpkg -l | grep -e apache -e php -e mysql -e graphviz -e ocs -e glpi | awk {'print $2" "$3'}):
apache2 2.2.9-10+lenny4
apache2-mpm-prefork 2.2.9-10+lenny4
apache2-utils 2.2.9-10+lenny4
apache2.2-common 2.2.9-10+lenny4
glpi 0.72-1
graphviz 2.20.2-3
libapache-dbi-perl 1.07-1
libapache2-mod-perl2 2.0.4-5
libapache2-mod-php5 5.2.6.dfsg.1-1+lenny3
libapache2-reload-perl 0.10-2
libdbd-mysql-perl 4.007-1
libgraphviz4 2.20.2-3
libmysqlclient15off 5.0.51a-24+lenny1
mysql-client-5.0 5.0.51a-24+lenny1
mysql-common 5.0.51a-24+lenny1
mysql-server 5.0.51a-24+lenny1
mysql-server-5.0 5.0.51a-24+lenny1
ocsinventory-agent 1:1.0.1-2
ocsinventory-reports 1.02.1-1
ocsinventory-server 1.02.1-1
php5 5.2.6.dfsg.1-1+lenny3
php5-common 5.2.6.dfsg.1-1+lenny3
php5-gd 5.2.6.dfsg.1-1+lenny3
php5-mcrypt 5.2.6.dfsg.1-1+lenny3
php5-mysql 5.2.6.dfsg.1-1+lenny3
phpmyadmin 4:2.11.8.1-5+lenny1

plugins for glpi:
Backups 1.4.0
Connections 1.5.0
Custom Fields 1.1.0
File injection 1.6.0
Human Resources 1.5.0
IP Adressing 1.7.0
Item's uninstallation 1.2.0
Network Architecture 1.7.0
Network tools 1.4.0
OCS import 1.3.0
Print to pdf 0.6.1
Reports 1.3.0
Rights 1.5.0
Salles 2.0
Shell Commands 1.2.0
Supplier import 1.2.0
Tables de Routage 1.1.0
Tree View 1.2.0
Web applications 1.5.0

5 (edited by artickl1 2009-07-24 19:36:54)

Re: Network Architecture plugin - problems

Sorry, I fond how it's work on French How-To for this plugin (http://www.glpi-project.org/wiki/doku.p … chires_use)... google trunslate rulezzz... )))
Sorry for previous post

H-m-m... With "Network tools" doesn't work. When install "Network tools" you can't see "red+" on top of it... But without it - it's perfect )))

6

Re: Network Architecture plugin - problems

artickl1 wrote:

H-m-m... With "Network tools" doesn't work. When install "Network tools" you can't see "red+" on top of it... But without it - it's perfect )))

When Network tools is installed, you use menu (view - add view)

Xavier Caillaud
Infotel, GOLD Partner for GLPI
Blog GLPI Infotel

7

Re: Network Architecture plugin - problems

After upgrating to GLPI v.0.72 and v.1.71 of Network Architecture plugin during setup of the plugin I've expirienced the following misbehavior - when choosing NETWORK device to config in the plugin dropdown, the system brings PRINTER types instead of NETWORK type to configure.
see the screenshot attached..
[img=http://img515.imageshack.us/img515/3773/networkarchpluginerror.th.gif]

8

Re: Network Architecture plugin - problems

https://dev.indepnet.net/plugins/changeset/11669

Thanks for your report

Xavier Caillaud
Infotel, GOLD Partner for GLPI
Blog GLPI Infotel